import re
regex = re.compile(r"<ul.*?\">(.*?)<\/ul>", flags=re.DOTALL)
test_str = ("<div id=\"outer\">\n"
"<ul id=\"ancTop\">\n"
"<li style=\"font-family: arial; font-size: 9pt;\">\n"
"<div style=\"overflow: hidden; width: 690px; height: 17px;\">\n"
" \n"
"<a href=\"#\"> \n"
"A90 - Lorem Ipsum \n"
"</a> \n"
"</div> \n"
"</li> \n"
"<li style=\"font-family: arial; font-size: 9pt;\"> \n"
"<div style=\"overflow: hidden; width: 690px; height: 17px;\"> \n"
" \n"
"<a href=\"#\"> \n"
"A85 - Lorem Ipsum \n"
"</a> \n"
"</div> \n"
"</li>\n"
"</ul>\n"
"</div>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")