const regex = /<ul.*?">(.*?)<\/ul>/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<ul.*?">(.*?)<\\\/ul>', 's')
const str = `<div id="outer">
<ul id="ancTop">
<li style="font-family: arial; font-size: 9pt;">
<div style="overflow: hidden; width: 690px; height: 17px;">
<a href="#">
A90 - Lorem Ipsum
</a>
</div>
</li>
<li style="font-family: arial; font-size: 9pt;">
<div style="overflow: hidden; width: 690px; height: 17px;">
<a href="#">
A85 - Lorem Ipsum
</a>
</div>
</li>
</ul>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}