using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<ul.*?"">(.*?)<\/ul>";
string input = @"<div id=""outer"">
<ul id=""ancTop"">
<li style=""font-family: arial; font-size: 9pt;"">
<div style=""overflow: hidden; width: 690px; height: 17px;"">
<a href=""#"">
A90 - Lorem Ipsum
</a>
</div>
</li>
<li style=""font-family: arial; font-size: 9pt;"">
<div style=""overflow: hidden; width: 690px; height: 17px;"">
<a href=""#"">
A85 - Lorem Ipsum
</a>
</div>
</li>
</ul>
</div>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}