import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<ul.*?\">(.*?)<\\/ul>";
final String string = "<div id=\"outer\">\n"
+ "<ul id=\"ancTop\">\n"
+ "<li style=\"font-family: arial; font-size: 9pt;\">\n"
+ "<div style=\"overflow: hidden; width: 690px; height: 17px;\">\n"
+ " \n"
+ "<a href=\"#\"> \n"
+ "A90 - Lorem Ipsum \n"
+ "</a> \n"
+ "</div> \n"
+ "</li> \n"
+ "<li style=\"font-family: arial; font-size: 9pt;\"> \n"
+ "<div style=\"overflow: hidden; width: 690px; height: 17px;\"> \n"
+ " \n"
+ "<a href=\"#\"> \n"
+ "A85 - Lorem Ipsum \n"
+ "</a> \n"
+ "</div> \n"
+ "</li>\n"
+ "</ul>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}