#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<script.*src=)("|')(.*)('|")"
Local $sString = "<script type="javascript" src='oldscript.js' ></script>" & @CRLF & _
"<img src='test.jpg' />"
Local $sSubst = "\1\2myscript.js\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)