use strict;
my $str = '<script type="javascript" src=\'oldscript.js\' ></script>
<img src=\'test.jpg\' />';
my $regex = qr/(<script.*src=)("|')(.*)('|")/p;
my $subst = '\\1\\2myscript.js\\4';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";