// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<script.*src=)("|')(.*)('|")"#).unwrap();
let string = "<script type=\"javascript\" src='oldscript.js' ></script>
<img src='test.jpg' />";
let substitution = "\\1\\2myscript.js\\4";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}