using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<script.*src=)(""|')(.*)('|"")";
string substitution = @"\1\2myscript.js\4";
string input = @"<script type=""javascript"" src='oldscript.js' ></script>
<img src='test.jpg' />";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}