const regex = /(<script.*src=)("|')(.*)('|")/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<script.*src=)("|\')(.*)(\'|")', '')
const str = `<script type="javascript" src='oldscript.js' ></script>
<img src='test.jpg' />`;
const subst = `\1\2myscript.js\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);