package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<script.*src=)("|')(.*)('|")`)
var str = []byte(`<script type="javascript" src='oldscript.js' ></script>
<img src='test.jpg' />`)
var substitution = []byte("\1\2myscript.js\4")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}