re = /(<script.*src=)("|')(.*)('|")/
str = '<script type="javascript" src=\'oldscript.js\' ></script>
<img src=\'test.jpg\' />'
subst = '\\1\\2myscript.js\\4'
result = str.sub(re, subst)
# Print the result of the substitution
puts result