using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\/\[JsonProperty\(Required = Required\.Always\)\])
(public string (My)(Property)(Name) { get; set; })";
string substitution = @"$1\n [JsonPropertyName(""\L$3_\L$4_\L$5"")]\n $2";
string input = @"//[JsonProperty(Required = Required.Always)]
public string MyPropertyName { get; set; }";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}