use strict;
my $str = '//[JsonProperty(Required = Required.Always)]
public string MyPropertyName { get; set; }';
my $regex = qr/(\/\/\[JsonProperty\(Required = Required\.Always\)\])
(public string (My)(Property)(Name) { get; set; })/mp;
my $subst = '$1\\n [JsonPropertyName("\\L$3_\\L$4_\\L$5")]\\n $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";