// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\/\/\[JsonProperty\(Required = Required\.Always\)\])
(public string (My)(Property)(Name) { get; set; })").unwrap();
let string = "//[JsonProperty(Required = Required.Always)]
public string MyPropertyName { get; set; }";
let substitution = "$1\\n [JsonPropertyName(\"\\L$3_\\L$4_\\L$5\")]\\n $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}