re = /(\/\/\[JsonProperty\(Required = Required\.Always\)\])
(public string (My)(Property)(Name) { get; set; })/m
str = '//[JsonProperty(Required = Required.Always)]
public string MyPropertyName { get; set; }'
subst = '$1\\n [JsonPropertyName("\\L$3_\\L$4_\\L$5")]\\n $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result