const regex = /(\/\/\[JsonProperty\(Required = Required\.Always\)\])
(public string (My)(Property)(Name) { get; set; })/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\\/\\[JsonProperty\\(Required = Required\\.Always\\)\\])
(public string (My)(Property)(Name) { get; set; })', 'gm')
const str = `//[JsonProperty(Required = Required.Always)]
public string MyPropertyName { get; set; }`;
const subst = `$1\n [JsonPropertyName("\L$3_\L$4_\L$5")]\n $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);