# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^"[^"\\]*(?:\\.[^\"\\]*)*"$|^'[^'\\]*(?:\\.[^'\\]*)*'$|^\s*["'][^"'\\]*|["']\s*$|\\.|(["'])[^"'\\\n]*/\\$1/gm;t' <<< "\"Some Text\"
\"Some more Text\"
\"Even more text about \\"this text\\"\"
\"Ol' 8 o'clock\"
'8 o'clock'
'8 o'clock'
'Ol' 8 o'clock'
\"\"B\"
\"\\"B\"
\"\\\"B\"
\"\\\\"B\"
\"\\\\\"B\""