use strict;
my $str = '"Some Text"
"Some more Text"
"Even more text about \\"this text\\""
"Ol\' 8 o\'clock"
\'8 o\'clock\'
\'8 o\'clock\'
\'Ol\' 8 o\'clock\'
""B"
"\\"B"
"\\\\"B"
"\\\\\\"B"
"\\\\\\\\"B"';
my $regex = qr/^"[^"\\]*(?:\\.[^\"\\]*)*"$|^'[^'\\]*(?:\\.[^'\\]*)*'$|^\s*["'][^"'\\]*|["']\s*$|\\.|(["'])[^"'\\\n]*/mp;
my $subst = '\\\\$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";