import Foundation
let pattern = #"^"[^"\\]*(?:\\.[^\"\\]*)*"$|^'[^'\\]*(?:\\.[^'\\]*)*'$|^\s*["'][^"'\\]*|["']\s*$|\\.|(["'])[^"'\\\n]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"Some Text"
"Some more Text"
"Even more text about \"this text\""
"Ol' 8 o'clock"
'8 o'clock'
'8 o'clock'
'Ol' 8 o'clock'
""B"
"\"B"
"\\"B"
"\\\"B"
"\\\\"B"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)