// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^"[^"\\]*(?:\\.[^\"\\]*)*"$|^'[^'\\]*(?:\\.[^'\\]*)*'$|^\s*["'][^"'\\]*|["']\s*$|\\.|(["'])[^"'\\\n]*"#).unwrap();
let string = "\"Some Text\"
\"Some more Text\"
\"Even more text about \\\"this text\\\"\"
\"Ol' 8 o'clock\"
'8 o'clock'
'8 o'clock'
'Ol' 8 o'clock'
\"\"B\"
\"\\\"B\"
\"\\\\\"B\"
\"\\\\\\\"B\"
\"\\\\\\\\\"B\"";
let substitution = "\\\\$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}