import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"[^\"\\\\]*(?:\\\\.[^\\\"\\\\]*)*\"$|^'[^'\\\\]*(?:\\\\.[^'\\\\]*)*'$|^\\s*[\"'][^\"'\\\\]*|[\"']\\s*$|\\\\.|([\"'])[^\"'\\\\\\n]*";
final String string = "\"Some Text\"\n"
+ "\"Some more Text\"\n"
+ "\"Even more text about \\\"this text\\\"\"\n"
+ "\"Ol' 8 o'clock\"\n"
+ "'8 o'clock'\n"
+ " '8 o'clock'\n"
+ "'Ol' 8 o'clock'\n"
+ "\"\"B\"\n"
+ "\"\\\"B\"\n"
+ "\"\\\\\"B\"\n"
+ "\"\\\\\\\"B\"\n"
+ "\"\\\\\\\\\"B\"";
final String subst = "\\\\$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}