#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^"[^"\\]*(?:\\.[^\"\\]*)*"$|^'[^'\\]*(?:\\.[^'\\]*)*'$|^\s*["'][^"'\\]*|["']\s*$|\\.|(["'])[^"'\\\n]*"
Local $sString = ""Some Text"" & @CRLF & _
""Some more Text"" & @CRLF & _
""Even more text about \"this text\""" & @CRLF & _
""Ol' 8 o'clock"" & @CRLF & _
"'8 o'clock'" & @CRLF & _
" '8 o'clock'" & @CRLF & _
"'Ol' 8 o'clock'" & @CRLF & _
"""B"" & @CRLF & _
""\"B"" & @CRLF & _
""\\"B"" & @CRLF & _
""\\\"B"" & @CRLF & _
""\\\\"B""
Local $sSubst = "\\$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)