$re = '/^"[^"\\\\]*(?:\\\\.[^\"\\\\]*)*"$|^\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'$|^\s*["\'][^"\'\\\\]*|["\']\s*$|\\\\.|(["\'])[^"\'\\\\\n]*/m';
$str = '"Some Text"
"Some more Text"
"Even more text about \\"this text\\""
"Ol\' 8 o\'clock"
\'8 o\'clock\'
\'8 o\'clock\'
\'Ol\' 8 o\'clock\'
""B"
"\\"B"
"\\\\"B"
"\\\\\\"B"
"\\\\\\\\"B"';
$subst = "\\$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;