using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^""[^""\\]*(?:\\.[^\""\\]*)*""$|^'[^'\\]*(?:\\.[^'\\]*)*'$|^\s*[""'][^""'\\]*|[""']\s*$|\\.|([""'])[^""'\\\n]*";
string substitution = @"\\$1";
string input = @"""Some Text""
""Some more Text""
""Even more text about \""this text\""
""Ol' 8 o'clock""
'8 o'clock'
'8 o'clock'
'Ol' 8 o'clock'
""B""
""\""B""
""\\""B""
""\\\""B""
""\\\\""B""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}