# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+?)(<p>.+?<\\/p>)/<p>$1<\\/p>$2/gm;t' <<< "this is some <b>text</b><p>Beginning of a paragraph</p>"