re = /(.+?)(<p>.+?<\/p>)/m
str = 'this is some <b>text</b><p>Beginning of a paragraph</p>'
subst = '<p>$1<\\/p>$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result