import Foundation
let pattern = #"(.+?)(<p>.+?<\/p>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"this is some <b>text</b><p>Beginning of a paragraph</p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<p>$1<\/p>$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)