use strict;
my $str = 'this is some <b>text</b><p>Beginning of a paragraph</p>';
my $regex = qr/(.+?)(<p>.+?<\/p>)/mp;
my $subst = '<p>$1<\\/p>$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";