package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?)(<p>.+?<\/p>)`)
var str = `this is some <b>text</b><p>Beginning of a paragraph</p>`
var substitution = "<p>$1<\/p>$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}