using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)(<p>.+?<\/p>)";
string substitution = @"<p>$1<\/p>$2";
string input = @"this is some <b>text</b><p>Beginning of a paragraph</p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}