const regex = /(.+?)(<p>.+?<\/p>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?)(<p>.+?<\\\/p>)', 'gm')
const str = `this is some <b>text</b><p>Beginning of a paragraph</p>`;
const subst = `<p>$1<\/p>$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);