$re = '/(.+?)(<p>.+?<\/p>)/m';
$str = 'this is some <b>text</b><p>Beginning of a paragraph</p>';
$subst = "<p>$1<\/p>$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;