// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+?)(<p>.+?<\/p>)").unwrap();
let string = "this is some <b>text</b><p>Beginning of a paragraph</p>";
let substitution = "<p>$1<\\/p>$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}