# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\([^()]*(?2)?[^()]*\))|\S+).ToHashSet\(\)/new HashSet<placeholder>($1)/gm;t' <<< "____.ToHashSet()
(something).ToHashSet()
(some (nested (object) i ) need).ToHashSet()
(some
(nested (object) with )
linebreaks).ToHashSet()"