re = /((\([^()]*(?2)?[^()]*\))|\S+).ToHashSet\(\)/m
str = '____.ToHashSet()
(something).ToHashSet()
(some (nested (object) i ) need).ToHashSet()
(some
(nested (object) with )
linebreaks).ToHashSet()'
subst = 'new HashSet<placeholder>($1)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result