import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\([^()]*(?2)?[^()]*\\))|\\S+).ToHashSet\\(\\)";
final String string = "____.ToHashSet()\n\n"
+ "(something).ToHashSet()\n\n"
+ "(some (nested (object) i ) need).ToHashSet()\n\n"
+ "(some \n"
+ "(nested (object) with ) \n"
+ "linebreaks).ToHashSet()";
final String subst = "new HashSet<placeholder>($1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}