$re = '/((\([^()]*(?2)?[^()]*\))|\S+).ToHashSet\(\)/m';
$str = '____.ToHashSet()
(something).ToHashSet()
(some (nested (object) i ) need).ToHashSet()
(some
(nested (object) with )
linebreaks).ToHashSet()';
$subst = "new HashSet<placeholder>($1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;