import re
regex = re.compile(r"((\([^()]*(?2)?[^()]*\))|\S+).ToHashSet\(\)", flags=re.MULTILINE)
test_str = ("____.ToHashSet()\n\n"
"(something).ToHashSet()\n\n"
"(some (nested (object) i ) need).ToHashSet()\n\n"
"(some \n"
"(nested (object) with ) \n"
"linebreaks).ToHashSet()")
subst = "new HashSet<placeholder>($1)"
result = regex.sub(subst, test_str)
if result:
print(result)