import Foundation
let pattern = #"((\([^()]*(?2)?[^()]*\))|\S+).ToHashSet\(\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
____.ToHashSet()
(something).ToHashSet()
(some (nested (object) i ) need).ToHashSet()
(some
(nested (object) with )
linebreaks).ToHashSet()
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"new HashSet<placeholder>($1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)