#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((\([^()]*(?2)?[^()]*\))|\S+).ToHashSet\(\)"
Local $sString = "____.ToHashSet()" & @CRLF & _
"" & @CRLF & _
"(something).ToHashSet()" & @CRLF & _
"" & @CRLF & _
"(some (nested (object) i ) need).ToHashSet()" & @CRLF & _
"" & @CRLF & _
"(some " & @CRLF & _
"(nested (object) with ) " & @CRLF & _
"linebreaks).ToHashSet()"
Local $sSubst = "new HashSet<placeholder>($1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)