use strict;
my $str = '
Surname NAME
34 Years
......... .. "';
my $regex = qr/[\r\n\t]+(.+[\r\n\t]+.+)[\t\r\n]+/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";