// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\r\n\t]+(.+[\r\n\t]+.+)[\t\r\n]+").unwrap();
let string = "
Surname NAME
34 Years
......... .. \"";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}