# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ (\s*<\\/p>\s*<p>){2,}/ <\\/p><p>/g;t' <<< "<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p></p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p>
</p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p> </p><p> paragraph3</p>"