const regex = / (\s*<\/p>\s*<p>){2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' (\\s*<\\\/p>\\s*<p>){2,}', 'g')
const str = `<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p></p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p>
</p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p> </p><p> paragraph3</p>`;
const subst = ` <\/p><p>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);