re = / (\s*<\/p>\s*<p>){2,}/
str = '<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p></p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p>
</p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p> </p><p> paragraph3</p>'
subst = ' <\\/p><p>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result