use strict;
my $str = '<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p></p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p>
</p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p> </p><p> paragraph3</p>';
my $regex = qr/ (\s*<\/p>\s*<p>){2,}/p;
my $subst = ' <\\/p><p>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";