import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (\\s*<\\/p>\\s*<p>){2,}";
final String string = "<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p></p><p> paragraph3</p>\n\n"
+ "<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p>\n"
+ "</p><p> paragraph3</p>\n\n"
+ "<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p> </p><p> paragraph3</p>";
final String subst = " <\\/p><p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}