// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r" (\s*<\/p>\s*<p>){2,}").unwrap();
let string = "<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p></p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p>
</p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p> </p><p> paragraph3</p>";
let substitution = " <\\/p><p>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}