using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (\s*<\/p>\s*<p>){2,}";
string substitution = @" <\/p><p>";
string input = @"<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p></p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p>
</p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p> </p><p> paragraph3</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}