$re = '/ (\s*<\/p>\s*<p>){2,}/';
$str = '<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p></p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p>
</p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p> </p><p> paragraph3</p>';
$subst = " <\/p><p>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;